Newly Created NSX-T Segments Do Not Appear in vCenter Inventory
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Newly Created NSX-T Segments Do Not Appear in vCenter Inventory

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Article ID: 380490

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Updated On:

Products

VMware NSX

Issue/Introduction

  • When creating a segment on the NSX-T Manger is not displayed on vCenter.
  • Login to the NSX manager as user admin. Switch to the root user by running the command st en
  • Checking the NSX manager log file in /var/log/proton/nsxapi.log below error are seen.
    ERROR LogicalSwitchStateOperationScheduler1 NsxPortgroupExecuteVcUtils 5140 SWITCHING [nsx@6876 comp="nsx-manager" errorCode="MP9538" level="ERROR" subcomp="manager"] Could not find the HostSwitch [ ## ## ## ## ## ## ## ## ## ## ## ## ## ## ##] of type VDS

Environment

VMware NSX

Cause

The ESXi (transport nodes) that were previously functioning and later decommissioned via vCenter Inventory, has not been removed from NSX completely

Resolution

This is a condition that can occur in a VMware NSX environment.

To fix the issue, follow the steps below

    • In the NSX-Ui navigate to  System > Fabric > Hosts > Standalone and remove the decommissioned Hosts using a DELETE NSX and then select the “Force Delete” option 

    • Login in the vCenter UI(Home > Inventory > Networking)  and ensure that the segment is created successfully.

Additional Information

For further help, please open a Broadcom support case