Problem:
The following error occurs during the installation of CA Service Desk Management:
[InstallCDB] Creation of CDB failed
java.lang.Exception: java.io.IOException: Cannot run program ""F:\\scripts\CDB\setupmdb.bat"" (in directory "F:\scripts\CDB"): CreateProcess error=193, %1 is not a valid Win32 application
at com.ca.smsi.installui.tasks.InstallCDB.executeCommand(InstallCDB.java:421)
at com.ca.smsi.installui.tasks.InstallCDB.installDatabase(InstallCDB.java:180)
at com.ca.smsi.installui.tasks.InstallCDB.run(InstallCDB.java:44)
at com.ca.smsi.wizard.task.Task.start(Task.java:222)
at com.ca.smsi.installcore.DeployThread.run(DeployThread.java:455)
Caused by: java.io.IOException: Cannot run program ""F:\\scripts\CDB\setupmdb.bat"" (in directory "F:\scripts\CDB"): CreateProcess error=193, %1 is not a valid Win32 application
at java.lang.ProcessBuilder.start(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at java.lang.Runtime.exec(Unknown Source)
at com.ca.smsi.installui.tasks.InstallCDB.executeCommand(InstallCDB.java:405)
... 4 more
Caused by: java.io.IOException: CreateProcess error=193, %1 is not a valid Win32 application
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.<init>(Unknown Source)
at java.lang.ProcessImpl.start(Unknown Source)
... 8 more
Cause:
The media files are damaged
Resolution/Workaround:
1. Uninstall Service Desk Manager
2. Download the media files again from http://support.ca.com
3. Mount the ISO file.
4. Start the installation process again