Cores were missing in the report due to the vCenter collection issue.
search cancel

Cores were missing in the report due to the vCenter collection issue.

book

Article ID: 380483

calendar_today

Updated On:

Products

VMware Usage Meter

Issue/Introduction

The VC collector is encountering an "Out of Memory" error.

collection-vcenter-error.log

ERROR --- [pool-5-thread-1] c.vmware.um.collector.CollectionHelper   : OutOfMemoryError collecting from server 16
java.lang.OutOfMemoryError: Java heap space
        at org.bouncycastle.crypto.internal.modes.gcm.Tables8kGCMMultiplier.multiplyH(Unknown Source)
        at org.bouncycastle.crypto.internal.modes.GCMBlockCipher.gHASHBlock(Unknown Source)
        at org.bouncycastle.crypto.internal.modes.GCMBlockCipher.gCTRBlock(Unknown Source)
        at org.bouncycastle.crypto.internal.modes.GCMBlockCipher.outputBlock(Unknown Source)

Environment

VMware vCloud Usage Meter 4.x

Cause

This issue occurs when the UM appliance has the large number of unprocessed events causing read timeout during the event collection process.

ERROR --- [pool-5-thread-1] com.vmware.um.vccollector.VCCollector    : Events stage raised exception javax.xml.ws.WebServiceException: java.net.SocketTimeoutException: Read timed out
javax.xml.ws.WebServiceException: java.net.SocketTimeoutException: Read timed out

Resolution

To resolve this issue:

  • Ensure Usage Meter appliance memory is minimum of 10GB.
  • Then, to increase the operating memory for VC collector from 1024MB to 3072MB.
    • Update the value of vcenter collector’s extraJavaOpts property in the file below:
      /opt/vmware/cloudusagemetering/platform/conf/schedule-executions/command.yml
    • Reboot the appliance

Additional Information

Collector logs are located at: /opt/vmware/cloudusagemetering/platform/log/

The Journal logs are located at: /opt/vmware/cloudusagemetering/platform/log/vmware-um-journal.log