Error SAML configuration was not able to be updated - Creating new saml configurations is disabled
search cancel

Error SAML configuration was not able to be updated - Creating new saml configurations is disabled

book

Article ID: 380446

calendar_today

Updated On:

Products

Carbon Black Cloud Endpoint Standard Carbon Black Cloud Endpoint Standard (formerly Cb Defense) Carbon Black Cloud Enterprise EDR (formerly Cb Threathunter)

Issue/Introduction

When trying to enable SAML in Carbon Black Cloud, the administrator sees the error:

SAML configuration was not able to be updated
Creating new saml configurations is disabled

Environment

  • Carbon Black Cloud Console: All versions
  • Carbon Black Cloud Sensors: All versions

Cause

Carbon Black Cloud is currently undergoing a migration to Authhub as described in the Carbon Black Cloud AuthHub Migration FAQ

Resolution

During this time, current SAML authentication will continue to work, however a new setup OR disabling / reenabling of SAML will not work.

Additional Information

This migration was announced on our community site and via a September 2024 IPN (Console notification) "AWARENESS: Changes to Carbon Black Cloud Login Process This Week"