Error message 'ConfigException occured 'ConfigDll could not find the config toolbox' when running a task to join a computer to the domain.
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Error message 'ConfigException occured 'ConfigDll could not find the config toolbox' when running a task to join a computer to the domain.

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Article ID: 380419

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Updated On:

Products

IT Management Suite Deployment Solution

Issue/Introduction

You are trying to re-image pre-existing client computers. While running a task to "join a computer to the domain" (Creating System Configuration Settings (broadcom.com)), the task is erroring with the following message:

ErrorMessage: ConfigException occured 'ConfigDll could not find the config toolbox', return code 0, system error 'The system cannot find the file specified (0x00000002)', location 'ConfigDll.cpp:154'

If you run the task but don’t specify an OU to move it to, it works fine and is joined and placed under the root "Computers" OU.
If you specify an OU, you get this error above.
You’ve checked that the OU you’ve specified in the task exists, and you’ve re-confirmed the account in question has rights to move computers into the task’s specified OU when done directly via AD Users and Computers (as well, it does work if you join the domain manually with those same credentials).

This "join a computer to the domain" task started to give the above message after upgrading to Deployment Solution 8.7

Cause

SMA (Symantec Management Agent) and DS (Deployment Solution) plugin upgrade were not enabled during Image deployment.

Resolution

Check the following:

  1. Check if your issue is related to missing config.dll as mentioned in KB 267422 - ConfigException occured 'ConfigDll could not find the config toolbox'
  2. Collect and review relevant logs:
    a) Agent logs
    b) netsetup.log (NetSetup log file in C:\Windows\debug on the local machine)
    c) DSTasks.log
  3. Look at your "Deploy Image" task. There is the options that you can enable for making sure the most current agent version is in place (this "Symantec Management Agent Settings" section didn't exists on pre-8.7 versions):
     "Upgrade Symantec Management Agent to the latest version"

    As well, make sure the Deployment Solution Agent Plug-in for Windows has the option to "Install or Upgrade"

The option in the task doesn't require standalone agent / plug-in policies to be enabled.

Additional Information

"Domain joins fail after installing October 2022 windows updates" (KB 254267)

Microsoft's netsetup.log file is a valuable resource when you troubleshoot a domain join issue. The netsetup.log file is located at C:\Windows\Debug\netsetup.log per the following KB:

Active Directory domain join troubleshooting guidance