Plan Patching/Plan Upgrading screen does not populate in SDDC Manager 5.2.1
search cancel

Plan Patching/Plan Upgrading screen does not populate in SDDC Manager 5.2.1

book

Article ID: 380402

calendar_today

Updated On:

Products

VMware Cloud Foundation 5.x

Issue/Introduction

  • When selecting either the Plan Upgrade or Plan Patching option the upgrade plan does not load. 
  • We see the following error in the /var/log/vmware/vcf/lcm/lcm-debug.log

    xxxx-xx-xxxxx:xx:xx.xxx+xxxx INFO  [vcf_lcm,] [c.v.e.s.l.p.i.v.rdu.RduClientImpl,http-nio-127.0.0.1-7400-exec-8] Check whether target version 6.7.0-19300125 is compatible with minimum supported target version 8.0.3.00200
    xxxx-xx-xxxxx:xx:xx.xxx+xxxx ERROR [vcf_lcm,d127f08f9d0f48fe,59f0] [c.v.v.l.r.a.c.v.u.UpgradableController,http-nio-127.0.0.1-7400-exec-8] Get SupportedUpgradeMechanisms for vCenter Failed with exception java.lang.RuntimeException: Versions are not in proper format - X.Y.Z.UPPHH-<Build Number>

Environment

VMware Cloud Foundation 5.2.1

Cause

Stale 6.7 and 6.5 vCenter bundle references in the LCM database. 

Resolution

1. SSH into the SDDC manager appliance with vcf user and elevate to root with su

2. Copy the cleanup_vc_bundles_lt7.py  script from the KB to the /home/vcf/ directory on the SDDC manager. 

3. Run the cleanup_vc_bundles_lt7.py with the below command. (The script will cycle the lcm service)

python cleanup_vc_bundles_lt7.py

4.Wait several minutes and retry the Plan Patching workflow in the SDDC Manager UI. 
(It may take 10-15 minutes for the screen to populate)

Attachments

cleanup_vc_bundles_lt7.py get_app