Endpoints are unable to download its packages: Failed to find adapter for any best interface
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Endpoints are unable to download its packages: Failed to find adapter for any best interface

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Article ID: 380262

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Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

You noticed that most of your client machines are not downloading its packages. The agent logs shows this type of entries:

Entry 1:

Download package '{53198B5A-D213-4A93-93F5-985E06995409}' from' \\SERVER-ps15.EXAMPLE.COM\PkgSvrHostD$\{53198B5A-D213-4A93-93F5-985E06995409}\cache', local blocks: 0/6, server blocks: 0/0, bytes in cache: 0
-----------------------------------------------------------------------------------------------------
Date: 10/18/2024 2:14:01 PM, Tick Count: 209297953 (2.10:08:17.9530000), Host Name: ComputerA, Size: 444 B
Process: AeXNSAgent.exe (16376), Thread ID: 8728, Module: AeXPackageDelivery.dll
Priority: 4, Source: PackageDownload

Entry 2:

Resolving outbound site for SERVER-ps15.EXAMPLE.COM: Failed to find adapter for any best interface
-----------------------------------------------------------------------------------------------------
Date: 10/18/2024 2:14:01 PM, Tick Count: 209297953 (2.10:08:17.9530000), Host Name: ComputerA, Size: 325 B
Process: AeXNSAgent.exe (16376), Thread ID: 8728, Module: AeXNSAgent.exe
Priority: 2, Source: ConfigServer

Entry 3:

Failed to get site ID for remote host: SERVER-ps15.EXAMPLE.COM. The transfer will be threated as outbound, error: No network adapters are available (0x80071712)
-----------------------------------------------------------------------------------------------------
Date: 10/18/2024 2:14:01 PM, Tick Count: 209297953 (2.10:08:17.9530000), Host Name: ComputerA, Size: 395 B
Process: AeXNSAgent.exe (16376), Thread ID: 8728, Module: AeXPackageDelivery.dll
Priority: 4, Source: SiteTransfer

Entry 4:

Operation 'Direct: Get' failed. 
Url: HTTPS://SERVER-ns.EXAMPLE.COM:443/Altiris/NS/Agent/SiteTransfer.aspx?xml=%3Cresource%20guid='%7B3ED4D480-1336-455C-BB6C-4D6767B4B182%7D'%20op='Start'%3E%3Csite%3E%7B897727A5-F743-4169-AED4-894B3200C5B8%7D%3C%2Fsite%3E%3Centity%3E%7B53198B5A-D213-4A93-93F5-985E06995409%7D%3C%2Fentity%3E%3Cmax%3E10%3C%2Fmax%3E%3Ctotal%3E9080161%3C%2Ftotal%3E%3Cdone%3E0%3C%2Fdone%3E%3Cspeed%3E0%3C%2Fspeed%3E%3C%2Fresource%3E 
Connection path: 1* - Direct: [SUBNET.150] -> SERVER-ns.EXAMPLE.COM [SUBNET.191:443] 
Connection id: 11.16376 
Communication profile id: {c786a603-508e-4a84-bd07-1063b7f30abc} 
Throttling: 2 30 5000 
Connecton stage: DNS resolve 
Error type: SMP Server error 
Error code: The specified resource is not ready. This condition is temporary and will be resolved by the next collection update (0x8004200D) 
Error note: SMP server failed the request 
Server SSL connection info: 
   Server certificate: 
      Serial number: xx xx xx xx a1 b3 a8 ac 4e 63 xx xx xx xx ca b3 
      Thumbprint: xx xx xx xx 24 9a dc 9b f8 ed dc 33 24 e2 xx xx xx xx 16 5b 
   Client certificate: 
      Serial number: N/A 
      Thumbprint: N/A 
   Cryptographic protocol: TLS 1.3 
   Cipher suite: TLS_AES_256_GCM_SHA384 
   Cipher algorithm: AES 
   Cipher key length: 256 
   Hash algorithm:  
   Hash length: 0 
   Key exchange algorithm:  
   Key length: 0 
Client SSL attributes for server connection: 
   Client certificate: 
      Serial number: N/A 
      Thumbprint: N/A 
   Cryptographic protocol: TLS 1.2, 1.3
Connection path id: 56 25 ab 23 54 90 f3 4d b6 22 f2 f4 2c 7b 1a 59 8d d3 a9 e8
-----------------------------------------------------------------------------------------------------
Date: 10/18/2024 2:14:01 PM, Tick Count: 209297984 (2.10:08:17.9840000), Host Name: ComputerA, Size: 1.84 KB
Process: AeXNSAgent.exe (16376), Thread ID: 8728, Module: AeXNetComms.dll
Priority: 1, Source: NetworkOperation

Entry 5:

Failed to start files downloading: the limit of site outbound data transfers is reached
-----------------------------------------------------------------------------------------------------
Date: 10/18/2024 2:14:01 PM, Tick Count: 209297984 (2.10:08:17.9840000), Host Name: ComputerA, Size: 326 B
Process: AeXNSAgent.exe (16376), Thread ID: 8728, Module: AeXPackageDelivery.dll
Priority: 2, Source: SiteTransfer

Entry 6:

Error while downloading package: The specified resource is not ready. This condition is temporary and will be resolved by the next collection update
-----------------------------------------------------------------------------------------------------
Date: 10/18/2024 2:14:01 PM, Tick Count: 209297984 (2.10:08:17.9840000), Host Name: ComputerA, Size: 390 B
Process: AeXNSAgent.exe (16376), Thread ID: 8728, Module: AeXPackageDelivery.dll
Priority: 1, Source: PackageDelivery

If you look at the Log.xml from one of those packages, it has:

<Download version="1716052939" status="retrying" statusDescr="No server found" nextRetry="2024-10-18 10:17:09" transferBytes="0" packageSize="9080161">
        <Session startTime="2024-10-18 09:52:37" endTime="2024-10-18 09:53:09" source="" transferRate="0" transferBytes="0" transferCache="0" result="-2147467259"/>
    </Download>

However, after a while, the client machines are able to start downloading its packages.

Environment

ITMS 8.7.1, 8.7.2

Cause

In this example, there is a "site server transfer policy" enabled and configured to allow maximum 10 outbound transfers:

Operation 'Direct: Get' failed. 
Url: HTTPS://SERVER-ns.EXAMPLE.COM:443/Altiris/NS/Agent/SiteTransfer.aspx?xml=%3Cresource%20guid='%7B3ED4D480-1336-455C-BB6C-4D6767B4B182%7D'%20op='Start'%3E%3Csite%3E%7B897727A5-F743-4169-AED4-894B3200C5B8%7D%3C%2Fsite%3E%3Centity%3E%7B53198B5A-D213-4A93-93F5-985E06995409%7D%3C%2Fentity%3E%3Cmax%3E10%3C%2Fmax%3E%3Ctotal%3E9080161%3C%2Ftotal%3E%3Cdone%3E0%3C%2Fdone%3E%3Cspeed%3E0%3C%2Fspeed%3E%3C%2Fresource%3E 

The 8.7 agent decides that the download is outbound and applies "site server transfer policy" and then SMP server denies download request with "not ready" error, which means more than 10 transfers are already in progress.

If a "site server transfer policy" is turned ON (in this example has very low limits,10 simultaneous downloads only), if they have 2500 problematic agents then it can take a while for all of them to download the package.

NOTE:

There should be records like:

Site Bandwidth: Agents: 500 site transfers: 100, local transfers: 50, bandwidth limit: 8192 bytes/sec, used bandwidth: 8192 bytes/sec"

But they are not logged constantly, so if something else fills the log then those records can be lost.

Resolution

Verify the following:

  1. Under SMP Console > Settings menu > Notification Server >Site Server Management > Site Server Settings > Targeted Site Settings, see if "Non-Internet Site Settings" is enabled.
    Note: this policy is used for Use transfer size limitation for required Sites or other options to avoid packages downloading from SMP Server or from Package Server

  2. If it is enabled, check the values for "Number of simultaneous data transfers" and "Maximum overall transfer speed (KB/s)"



    In this example, the customer had a value of "10" for the "Number of simultaneous data transfers"



  3. Turn OFF "Non-Internet Site Settings" policy (or "Internet Site Settings" policy if the issue happens on CEM connected client machines) and see if the issue is cleared out for those client machines that were having the issue. By default, these two policies are turned OFF:



  4. If the issue is no longer present and you want to continue using these Site transfer policies ("Non-Internet Site Settings" policy (or "Internet Site Settings" policy if the issue happens on CEM connected client machines)), increase the previous "Number of simultaneous data transfers" value so that more client machines can get the needed packages.