Proxy not connecting to Portal after Restart due to license expired for MAS
search cancel

Proxy not connecting to Portal after Restart due to license expired for MAS

book

Article ID: 380243

calendar_today

Updated On:

Products

CA API Developer Portal

Issue/Introduction

APIGW is not connecting to portal, because of MAS License issue . The error that comes because of the same is .

Failed connecting to Broker: wss://apim:1885/
Unable to connect to server (32103) - java.net.ConnectException: Connection refused (Connection refused)
 at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start(TCPNetworkModule.java:80)
 at org.eclipse.paho.client.mqttv3.internal.SSLNetworkModule.start(SSLNetworkModule.java:130)
 at org.eclipse.paho.client.mqttv3.internal.websocket.WebSocketSecureNetworkModule.start(WebSocketSecureNetworkModule.java:63)
 at org.eclipse.paho.client.mqttv3.internal.ClientComms$ConnectBG.run(ClientComms.java:722)
 at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.net.ConnectException: Connection refused (Connection refused)
 at java.base/java.net.PlainSocketImpl.socketConnect(Native Method)
 at java.base/java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
 at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
 at java.base/java.net.AbstractPlainSocketImpl.connect(Unknown Source)
 at java.base/java.net.SocksSocketImpl.connect(Unknown Source)
 at java.base/java.net.Socket.connect(Unknown Source)
 at java.base/sun.security.ssl.SSLSocketImpl.connect(Unknown Source)
 at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start(TCPNetworkModule.java:74)
 ... 4 more

Environment

5.1.2

Cause

The MAS license expired on 16th October. 

cat /opt/SecureSpan/Gateway/node/default/etc/bootstrap/license/MAS-license.xml
<?xml version="1.0" encoding="UTF-8"?>
<license Id="1234567890" xmlns="http://l7tech.com/license">
    <description>Layer7-Internal-PRODUCTION</description>
    <licenseAttributes/>
    <valid>2019-10-15T01:19:05.779Z</valid>
    <expires>2024-10-16T01:19:05.779Z</expires>
    <host name=""/>
    <ip address=""/>
    <product name="Layer 7 SecureSpan Suite">
        <version major="10" minor=""/>
        <featureset name="set:Profile:Mobile"/>
        <featureset name="set:Profile:MAS"/>
    </product>

Resolution

This is a bug in 5.1.2 and it is fixed in the hotfix release of 5.1.2.1 . Below is the place from where it can be downloaded .

https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/release-announcements/CA-API-Developer-Portal-Solutions--Patches/3010

note that it may have other fixes include, the below page has the listing of the issues that were fixed in 5.1.2.1.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-developer-portal/5-1-2/release-notes-api-developer-portal.html