MPLS installer does not list Installation Type (Install/Upgrade).
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MPLS installer does not list Installation Type (Install/Upgrade).

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Article ID: 380218

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Updated On:

Products

VMware Telco Cloud Service Assurance VMware Smart Assurance

Issue/Introduction

When Smarts MPLS need to be upgraded, installer must find existing installation for this suite and give users an option to either "Install product to a new directory" or "Upgrade existing suite".

However, user would not get options instead be forced to install to a new directory.

Installation window will be similar to below:

Choose to install "VMware Smart Assurance MPLS Management Suite" to this directory, or specify the directory path to install to a different directory.

  Default Install Folder: /opt/InCharge

ENTER AN ABSOLUTE PATH, OR PRESS <ENTER> TO ACCEPT THE DEFAULT
      :

Environment

Smarts - 10.1.0 till 10.1.7

Direct upgrade to Smarts-DM/TCSA-DM 2.x from 10.1.0 till 10.1.7 is also impacted hence TCSA - 2.x.

Cause

This is known issue with Smarts where Smarts should be tagging unique productID to each suites however starting from Smarts MPLS 10.1.0 till 10.1.7 both NPM and MPLS suites share same productID which would lead to impression that MPLS is not installed on the server if both NPM and MPLS are installed on same system. 

Resolution

Raise a Service Request (SR) with VMware by Broadcom Technical support team with this KB number (380218) mentioned where they would help to fix Installer Registry (.com.zerog.registry.xml).

This issue is fixed starting from Smarts version 10.1.9 onwards.