HCX - Service Mesh creation fails due to a permission error resulting the deployment failure of the IX/NE appliance
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HCX - Service Mesh creation fails due to a permission error resulting the deployment failure of the IX/NE appliance

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Article ID: 380209

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Updated On:

Products

VMware Cloud on AWS VMware HCX

Issue/Introduction

The following error is observed in /common/logs/admin/app.log:

2024-10-14 07:18:03.461 UTC [OvfUploadService_SvcThread-27, Ent: DEFAULT, , TxId: TxId: cfa510a3-03c3-402a-b6ab-4c4505d13bb2] ERROR c.v.v.h.s.ovfupload.OvfUploadJob- Error in uploading Ovf
com.vmware.vim.binding.vim.fault.NoPermission: Permission to perform this operation was denied.

The error is displayed on the HCX UI -> Interconnect -> More -> Tasks:

 

Environment

HCX

VMware Cloud on AWS

Cause

The error occurs when the vCenter username registered in the HCX Manager interface at https://hcx-ip-or-fqdn:9443 does not have the necessary permissions to perform all operations.

Resolution

Please follow these steps to re-register the vCenter:

1. Log in to the HCX Admin page at https://hcx-ip-or-fqdn:9443.
2. Navigate to Configuration > vCenter Server.
3. Ensure that the vCenter is registered using the "[email protected]" account.
4. Restart the Appliance and Web service from Appliance Summary tab.
5. Redeploy the Service Mesh again.

If you believe you have encountered this issue on VMware Cloud on AWS, please open a support case with Broadcom Support and refer to this KB article.
For more information, see Creating and managing Broadcom support cases

 

Additional Information

Workaround for VMware Cloud on AWS:
Ensure that the vCenter is registered using the "[email protected]" account - not cloudadmin.