The Incident Persister and the Detection Server Controller services will not start after installing the 16.0.2 software
search cancel

The Incident Persister and the Detection Server Controller services will not start after installing the 16.0.2 software

book

Article ID: 380131

calendar_today

Updated On:

Products

Data Loss Prevention Data Loss Prevention Enforce

Issue/Introduction

In preperation for migrating from 16.0.1 to 16.0.2, the 16.0.2 software was installed per the tech docs.
The migration has not been run.
The Incident Persister and the Detection Server Controller services will not start.
The IncidentPersister_0.log shows that the Incident Persister is attempting to access the 16.0.2 directories.
Again, the migration has not been run, neither phase 1 nor phase 2.

Cause

For some reason, the services conf files have been updated to the 16.0.2 version.

Resolution

  1. Make a backup copy of the services conf file.
    Windows: "...\DataLossPrevention\EnforceServer\Services"
    Linux: "/opt/Symantec/DataLossPrevention/EnforceServer/Services"
  2. Locate the old services backups directory.
    Windows: "DataLossPrevention/EnforceServer/16.0.10000/Protect\backups"
    Linux: "/opt/Symantec/DataLossPrevention/EnforceServer/16.0.10000/Protect/backups"
    Though due to this issue, the backups may be under the 16.0.2 directory path.
  3. Copy the RU1 backup services to the correct path.
    Windows: ".../DataLossPrevention/EnforceServer/16.0.10000/Protect\backups"
    Linux: "/opt/Symantec/DataLossPrevention/EnforceServer/16.0.10000/Protect/backups"
  4. Restart the system