There is indication on Aria Operations Web UI as below when editing account in Administration --> Integrations
"You are viewing this account configuration in read-only mode, because you are not the owner of these applied credentials. You will only be able to make changes to the account, if you provide your own credentials."
Failed to edit cloud account's credential;
Environment
Aria Operations 8.x
Cause
This issue can be reproduced with procedure below:
Create Aria Operations account Aria-Account-A with Administrator role;
Login Aria Operations with Aria-Account-A and create credential Cloud-Credential-A;
Login Aria Operations with local admin and delete Aria-Account-A;
Now Cloud-Credential-A cannot be edited because its owner Aria-Account-A has been removed.
Resolution
Login Aria Operations with local admin;
Go to Control Panel --> Orphaned and Unassigned --> Credentials,
Select the credential from "Deleted Users" list then do "Take ownership" or "Assign ownership" to change the ownership of the orphaned credential.