Adapter credentials in Aria Operations cannot be edited
search cancel

Adapter credentials in Aria Operations cannot be edited

book

Article ID: 380100

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • There is an indication on the Aria Operations product UI as below when editing account in Administration --> Integrations

    "You are viewing this account configuration in read-only mode, because you are not the owner of these applied credentials. You will only be able to make changes to the account, if you provide your own credentials."



  • Failed to edit cloud account's credentials.

Environment

Aria Operations 8.16.x and later versions.

Cause

This is a feature introduced since Aria Operations 8.16.x and it is working as designed.

Resolution

Solution:

    • Login Aria Operations with local user admin;
    • Go to Control Panel --> Orphaned and Unassigned --> Credentials,
    • Select the credential from "Deleted Users" list then do "Take ownership" or "Assign ownership" to change the ownership of the orphaned credential.

Additional Information

One can also choose to deactivate Credential ownership enforcement in global settings under Administration so that anyone can view/modify the credentials without any need of taking the ownership.

For more details on the feature refer to the below document: Credential ownership enforcement