Backup/tech-support files or logs may not be scped between controllers
search cancel

Backup/tech-support files or logs may not be scped between controllers

book

Article ID: 380062

calendar_today

Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

The symptoms for this issue can vary from the following:

Symptom 1: Config backup is enabled but not files being generated in the UI. From the controller bash, we can see the files are correctly generated under /var/lib/avi/backups directory


Symptom 2: Debug logs collection completes but no file is generated. 

 

Symptom 3: VS logs not loading in the UI

 

Steps to verify if we are hitting this issue

Check the status of aviscp_server service from the controller bash. This can be done by using the command systemctl status aviscp_server.service

If the service is in failed state on any of the 3 controller nodes, then the environment is running into this issue. 

Environment

Affects 22.1.x releases before 22.1.6 and 30.x.x releases before 30.2.1

Cause

This issue is caused because the aviscp service failure policies are incorrectly set on the cluster follower members. Hence if the aviscp_server service is terminated, it cannot be restarted thus leading to scp failure(s).

Resolution


Bug is fixed in 22.1.6 and 30.2.1 releases. 




Workaround is to manually restart the aviscp_server service using the below command
systemctl restart aviscp_server.service



If the service is not able to restarted, please reach out to support team for further assistance.