Get an error "Cannot install version 3.2.0.284 over an existing version" When we try to install Integration Services

book

Article ID: 37998

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

Issue:

Unable to reinstall Integration Framework from SOI 3.2 and installer once uninstalled and gives an error "cannot install version 3.2.0.284 over an existing version".

Cause:

This issue occurs because Installer Anywhere leaves behind certain entries which have to be manually removed.

 

Resolution: 

The appropriate process to uninstall IFW is

-      Uninstall IFW from appwiz.cpl (Uninstall or change a program) or using ‘Uninstall IntegrationServices.exe’ located in ..\CA\SOI\Uninstall IntegrationServices

-      Delete hidden ‘Zero G Registry’ folder from <Drive>:\Program Files (86)

But if in case you have Catalyst container also installed on the same machine then it is not recommended to delete ‘Zero G Registry’ folder as it will impact catalyst container.

In this situation we need to follow steps below:

-      Uninstall IFW using ‘Uninstall IntegrationServices.exe’ located in ..\CA\SOI\Uninstall IntegrationServices.

-      Make sure no ‘Integration Services’ is listed in appwiz.cpl if so uninstall it.

-      Rename SAM registry key to SAM.old if it is present in path HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\CA\SAM

-      Backup ..\Zero G Registry\.com.zerog.registry.xml to some other location

-      Delete the below block of data from ..\Zero G Registry\.com.zerog.registry.xml

------------

  <product name="Integration Services" id="4e14b92e-1f00-11b2-b226-b9ed5583a417" version="3.2.0.284" copyright="2013" info_url="http://www.ca.com/us/it-management-products.aspx" support_url="https://support.ca.com" location="C:\Program Files (x86)\CA\SOI" last_modified="2014-12-03 11:13:40">
  <![CDATA[CA Service Operations Insight - IntegrationServices (connector services)]]>
   <vendor name="CA, Inc." id="7f1ebb3c-1ec7-11b2-8037-c0d9e9f9d7a6" home_page="http://www.ca.com" email=""/>
   <feature short_name="ISInstaller" name="Integration Services - Installer" last_modified="2014-12-03 11:13:40">
   <![CDATA[SSA Connector Services - Standalone IFW installer]]>
    <component ref_id="4e0c0df1-1f00-11b2-b38c-b9ed5583a417" version="3.0.0.1" location="C:\Program Files (x86)\CA\SOI\Uninstall Integration Services\Uninstall Integration Services.exe"/>
    <component ref_id="d8062a5d-1eeb-11b2-af3f-8d473a1338a4" version="3.0.0.1" location="C:\Program Files (x86)\CA\SOI\jre"/>
    <component ref_id="d346f730-1eeb-11b2-af23-8d473a1338a4" version="3.2.0.1" location=""/>
   </feature>
  </product>

------------

<component id="d346f730-1eeb-11b2-af23-8d473a1338a4" version="3.2.0.1" name="Integration Services" location=""/>

------------

<component id="4e0c0df1-1f00-11b2-b38c-b9ed5583a417" version="3.0.0.1" name="InstallAnywhere Uninstall Component" location="C:\Program Files (x86)\CA\SOI\Uninstall Integration Services\Uninstall Integration Services.exe" vendor="CA, Inc."/>

------------

Note: In above block of data the drive letter will change as per location where componenet is installed.

Now you can rerun the IntegrationServices.exe and it should be successful.

Please Contact CA Support for any further questions.

Environment

Release:
Component: SAMIFW