"Unexpected Error: 500: Infinite historical event loop detected" in CA Performance Center

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Article ID: 37997

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Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

When using the CA Performance Center WEB UI, a sporadic POP-UP shows up with:

Unexpected Error: 500: Infinite historical event loop detected

 

PCServices.log shows errors similar to:

ERROR | Model-Invoker-1 | 2015-12-10 18:16:30,440 | com.ca.im.portal.plugins.rib.models.RIBXYChartModel 
| RIB query failed
Model ID/Type: {1000028/RIBXYChartModel}
Result status: {ERROR_SOURCE_INTERNAL_TIMEOUT}
Query ID: {2a8bb813-fc29-41ff-9d44-c829ad3f3889}
RIB source URL: {http://wx0587.dbadmin.danskenet.net:8281/EventManager/EventManagerRibWS.asmx}
Query: {SELECT .EventCount, .OccurredOn(300) FROM CA.Events.EventCounts WHERE .Item.itemID = 371763 AND .OccurredOn(300) >= 1449738840 AND .OccurredOn(300) <= 1449767640 GROUPBY .OccurredOn(300) ORDERBY .OccurredOn(300) ASC}
Reason: {Query exceeded specified timeout of 100}

Cause

Communication to Data Source times out due to slow response from Datasource or slow network

Environment

CAPC 2.x, 3.x

Resolution

Increase the Timeout in three different locations to for the environment.

  1. Change timeout for javascript: 

    a) In a browser, go to this URL after substituting "<CAPC_Host>". You will be prompted to log in - use your CAPC web 'admin' account. 
    http://<CAPC_Host>:8181/pc/center/admin/debug/attrs​

     

    b) Find the attribute called "Client.ServerExecutionTimeoutMs"
    c) Change the value to a large enough number, in milliseconds, to allow the query to run (for example, use 600000 to allow 10 minutes)
    d) Click on the "Update" button to apply the change.

  2. Change timeout for the request from console to the DM:

    a) Backup the portal.console.properties file

    cp /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/portal.console.properties /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/portal.console.properties.orig​


    b) Open this file in an editor:

    vi /opt/CA/PerformanceCenter/PC/webapps/pc/WEB-INF/cfg/portal.console.properties ​

    c) Change the setting for "web.cxf.client.services_timeout" to a high enough value to allow query to run (in milliseconds, for example, set to 600000 to allow 10 minutes)

    web.cxf.client.services_timeout=600000​


  3. Change timeout for how long the DM waits for a datasource to respond:

    a) Backup the rib-engine.properties file;
    cp /opt/CA/PerformanceCenter/DM/webapps/dm/WEB-INF/rib-engine.properties /opt/CA/PerformanceCenter/DM/webapps/dm/WEB-INF/rib-engine.properties.orig​

    b) Open this file in an editor:
    vi /opt/CA/PerformanceCenter/DM/webapps/dm/WEB-INF/rib-engine.properties ​

    c) Change the setting for "rib.engine.source_query_timeout_sec" to a high enough value to allow query to run (in seconds, for example, set to 600 to allow 10 minutes) 

    rib.engine.source_query_timeout_sec=600​

Additional Information

You may want to increase the Timeout step by step to find the best value.