Jaspersoft 9.0.0 Schedules fail to work after migration from Jasper Server 8.1.1
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Jaspersoft 9.0.0 Schedules fail to work after migration from Jasper Server 8.1.1

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Article ID: 379931

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

After the migration of Jasper Report Server (JRS)  8.1.1 to 9.0.0 with Oracle as the DB repository, existing schedules do not work anymore. The older schedules under the menu "Schedules and Alerts" cannot be edited, paused, or even deleted. The same actions on the new schedules created in JRS 9.0 work fine as expected.
 
Steps to replicate:
  1. Schedule some reports in JRS 8.1.1'
  2. Upgrade JRS 8.1.1 to 9.0
  3. Existing schedule reports stop working and report admins are no longer able to edit or view the report schedule properties
 
Expected Result:
The older schedules to work and properties of schedules to be working
 
Actual Result:
The older schedules do not work and a 500 internal server error was found on the browser trace for the background API calls when schedules are opened on the UI menu > Schedules and Alerts

Environment

Clarity 16.2.3 with Jaspersoft Server 9.0 running on Oracle 

Cause

DE155637 and Tibco bug: JS-7410

Resolution

The JRS 9.0 same DB upgrade script is updating the destination type value of the schedules in the underlying table JIREPORTJOBREPODEST to 11 when the expected value is 1.

The workaround solution would be to run the SQL update to correct all old schedules in the Jaspersoft table.

Update JIREPORTJOBREPODEST set dest_type = 1 where dest_type = 11