Adding HTTPS proxy to VMware Cloud Usage Meter 4.8 fails with error: Failed to connect to the proxy server
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Adding HTTPS proxy to VMware Cloud Usage Meter 4.8 fails with error: Failed to connect to the proxy server

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Article ID: 379911

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

  •  Adding HTTPS proxy to VMware Cloud Usage Meter fails with the below error:

          Failed to connect to the proxy server: unexpected_message(10); Unsupported UNKNOWN(72)'

  • Running echo | openssl s_client -connect proxy_server_IP:proxy_server_port on the Usage Meter shows:

         CONNECTED(00000003)
         C0410CD4977F0000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:ssl/record/ssl3_record.c:354:
         ---
         no peer certificate available
         ---
         No client certificate CA names sent
         ---
         SSL handshake has read 5 bytes and written 285 bytes
         Verification: OK

Environment

Usage Meter 4.8

Cause

  • The error C0410CD4977F0000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:ssl/record/ssl3_record.c:354: indicates that the proxy server is not accepting SSL/TLS connections on this port.
  • This happens when proxy server uses a different protocol than Usage Meter, like SOCKS (Socket Secure).

Resolution


    • Usage Meter does not support SOCKS proxy. Only HTTP and HTTPS proxy is supported.