vSphere Live Site Recovery Plugin Showing "Not Acessible" After Updating vCenter Thumbprint
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vSphere Live Site Recovery Plugin Showing "Not Acessible" After Updating vCenter Thumbprint

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Article ID: 379874

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Updated On:

Products

VMware Live Recovery VMware Site Recovery Manager 8.x

Issue/Introduction

After changing certificates on vCenter the SRM and vSphere replication 9.x plugins will show "Not Accessible"

 

Environment

vSphere Live Site Recovery 9.x

Cause

Existing 8.x Plugins in environment will not be updated for the new vCenter thumbprint and will override the current plugin connection after reconfiguring through VAMI interface
Plugins can be verified by going to Administration > Client Plugins. VMware Site Recovery will be listed twice and one of the plugins with be the 8.x version and one will be 9.x

Resolution

We will need to remove the 8.x plugin package from any vCenter that is in linked mode.

  1. Obtain SSH into all vCenter Servers in linked mode
  2. Verify if any stale plugin packages exist with "com.vmware.vrUi-8.X.X.XXXXXXXX"
    cd /etc/vmware/vsphere-ui/cm-service-packages/com.vmware.cis.vsphereclient.plugin
  3. Stop vSphere UI service
    service-control --stop vsphere-ui
  4. Remove all stale plugin packages
    rm -rf com.vmware.vrUi-8.x.x.xxxxxx
  5. Start up vSphere UI service
    service-control --start vsphere-ui

Log out and refresh the vCenter UI interface. Verify if Live Site Recovery Plugins are still showing Not Accessible

Additional Information

SRM and vSphere Replication will need to be reconfigured through the vami interfaces after changing vCenter thumbprints.