Error: Login to cloud with provided credentials failed
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Error: Login to cloud with provided credentials failed

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Article ID: 379860

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

Removing the workload cluster from the Harbor partner system displaysan  error: Login to cloud with provided credentials failed

Environment

2.2

2.3

Cause

When adding or removing a cluster to the Harbor Partner system. TCA will poll each cluster in the partner system if the certificate and kubeconfig are valid

The error indicates an issue with:

  • Certificate for a workload cluster
  • Cluster kubeconfig applied in Telco manager appliance
  • Cluster kubeconfig applied in the TCACP 9443 management interface

Resolution

To isolate the cluster that has the issue, search the TCACP for this error:

”Exception creating kubernetes session” 

1. SSH into TCACP and run

grep -irH "Exception creating kubernetes session" /common/logs/*
​​
If the error is found, then one or multiple clusters on that TCACP have a certificate issued or a kubeconfig issue.

For each suspected cluster

1. Copy the kubeconfig from the cluster control plane node at /etc/kubernetes/admin

2. Update the TCA Manager Clusters kubeconfig with one copied from /etc/kubernetes/admin
 
3. Update the TCA-CP 9443 Clusters kubeconfig with one copied from /etc/kubernetes/admin

4. Reboot TCAM and TCA-CP