The capacity of ‘/var/log/store’ directory in the Harbor Virtual Machine has increased.
search cancel

The capacity of ‘/var/log/store’ directory in the Harbor Virtual Machine has increased.

book

Article ID: 379792

calendar_today

Updated On:

Products

VMware Tanzu Kubernetes Grid Integrated (TKGi)

Issue/Introduction

Manual image deletion from the ‘Harbor User Interface’, space is not automatically freed up.

After the deletion of images in the 'Harbor', disk space for '/var/log/store' is not reclaimed.

Environment

Harbor version 2.10.0

Vmware's Tanzu Kubernetes Grid Integrated (TKGI) version 1.18.2

Cause

The root cause of the issue is that Harbor’s garbage collection process has not been triggered. The deletion of images from the UI only marks them as eligible for deletion, but the actual disk space is not reclaimed until garbage collection is run.

Resolution

To fully delete the images and reclaim disk space, you need to run Harbor's garbage collection.

Below are the steps:

  1. Log in to the Harbor interface with an account that has Harbor system administrator privileges.
  2. Expand Administration, and select Garbage Collection/Clean Up.
  3. Select the ‘Garbage Collection’ tab.
  4. To run garbage collection immediately, click GC Now. When you run garbage collection, Harbor goes into read-only mode. All modifications to the registry are prohibited.
  5. Verify the Space Reclamation:

    After the garbage collection completes, verify the space reclaimed on the /var/log/store directory :

    df -h /var/log/store

Additional Information

For more information Refer : https://goharbor.io/docs/1.10/administration/garbage-collection/

Attachments

Screenshot 2024-10-16 at 1.44.11 PM.png get_app