The CA Chorus Software Manager MSMTC may fail at startup when attempting to update the Master Catalog.

book

Article ID: 37970

calendar_today

Updated On:

Products

CA Mainframe Software Manager (Chorus Software Manager)

Issue/Introduction

Problem:

After installing a new release of CA Chorus Software Manager (CSM), the MSMTC task fails to initialize successfully.  
The messages show that the failure is due to insufficient authority when attempting to update a dataset in the Master Catalog.
The started task displays messages similar to the following:

STC12345  IEF695I START MSMTC WITH JOBNAME MSMTC  IS ASSIGNED TO USER MSMUSR, GROUP MSMGRP
STC12345  $HASP373 MSMTC STARTED
STC12345  IEF403I MSMTC - STARTED - TIME=12.34.56
STC12345  MSM0013I CA CSM STARTUP INITIATED
STC12345  ICH408I USER(MSMUSR ) GROUP(MSMGRP) NAME(MSM STC USERID)
           CATALOG.MASTCAT CL(DATASET) VOL(VOL321)
           INSUFFICIENT ACCESS AUTHORITY
           FROM CATALOG.MASTRCAT.** (G)
           ACCESS INTENT(UPDATE )  ACCESS ALLOWED(READ   )
STC12345  MSM0010E CA CSM STARTUP FAILED
STC12345  IEF404I MSMTC - ENDED - TIME=12.35.41
STC12345  $HASP395 MSMTC    ENDED


Environment:

CSM Release 6.0 and above in a z/OS Environment


Cause
:

There is no dataset High Level Qualifier (HLQ) defined in the csm.SAMPLIB DBINIT member

As distributed, the following parms are commented out in the csm.SAMPLIB DBINIT member

                   #sisGimunzipTempPrefix=TTECPMG
                                      - and -
                   #sisExecutorServerDsnPrefix=TTECPMG

Additionally, the csm.SAMPLIB(DBINIT) is allocated to the //DBINIT DD of the default MSMTC JCL 

 

Resolution:

  • Edit the csm.SAMPLIB DBINIT member and uncomment the statements above
  • Modify the MSMTC proc and change the DDNAME of //DBINIT to //DBUPDATE
  • Re execute the MSMTC STC   


Additional Resources:

Please refer to the following documentation regarding the DBINIT and DBUPDATE settings and usage: 

 

 

Environment

Release:
Component: MSM