Chorus Software Manager MSMTC may fail at startup when attempting to update the Master Catalog.
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Chorus Software Manager MSMTC may fail at startup when attempting to update the Master Catalog.

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Article ID: 37970

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Updated On:

Products

Mainframe Software Manager (Chorus Software Manager) CHORUS SOFTWARE MANAGER

Issue/Introduction

After installing a new release of Chorus Software Manager (CSM) / Mainframe Software Manager, the MSMTC task fails to initialize successfully.  
The messages show that the failure is due to insufficient authority when attempting to update a dataset in the Master Catalog.
The started task displays messages similar to the following:


STC12345  IEF403I MSMTC - STARTED - TIME=12.34.56
STC12345  MSM0013I CA CSM STARTUP INITIATED
STC12345  ICH408I USER(msmuser) GROUP(msmgroup) NAME(msmuser name)
           CATALOG.MASTCAT CL(DATASET) VOL(VOLxxx)
           INSUFFICIENT ACCESS AUTHORITY
           FROM CATALOG.MASTRCAT.** (G)
           ACCESS INTENT(UPDATE )  ACCESS ALLOWED(READ   )
STC12345  MSM0010E CA CSM STARTUP FAILED
STC12345  IEF404I MSMTC - ENDED - TIME=12.35.41
STC12345  $HASP395 MSMTC    ENDED

 

Cause

There is no dataset High Level Qualifier (HLQ) defined in the csm.SAMPLIB DBINIT member

As distributed, the following parms are commented out in the csm.SAMPLIB DBINIT member

                   #sisGimunzipTempPrefix=TTECPMG
                                      - and -
                   #sisExecutorServerDsnPrefix=TTECPMG

Additionally, the csm.SAMPLIB(DBINIT) is allocated to the //DBINIT DD of the default MSMTC JCL 

 

Resolution

  • Edit the csm.SAMPLIB DBINIT member and uncomment the statements above
  • Modify the MSMTC proc and change the DDNAME of //DBINIT to //DBUPDATE
  • Re execute the MSMTC STC   

Additional Information

** Chorus Software Manager (Mainframe Software Manager) is EOL starting July 2023 **