HCX - Unable to edit or Resync Service Mesh since another operation is in progress
search cancel

HCX - Unable to edit or Resync Service Mesh since another operation is in progress

book

Article ID: 379580

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • While resyncing, modifying, or creating a service mesh, you encounter the following error displayed on the HCX UI:
    Cannot create/modify service mesh <Service-Mesh-Name> since another operation is in progress
  • Restarting the HCX manager services has no effect, and the issue persists.
  • You are unable to see any other tasks running on the HCX.

Environment

HCX 4.x

Cause

This issue is caused by a stale entry, which typically occurs when an unextended network task is triggered multiple times. Repeated attempts to unextend a network can eventually cause a task to become stuck in the database.

Resolution

There will be improvements in future releases.

Workaround:
If you believe you have encountered this issue, please open a support case with Broadcom Support, upload source and destination HCX logs including the database dump, and refer to this KB article.
For more information, see Creating and managing Broadcom support cases.