Cannot login to Enterprise Manger due to error with managed connections.
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Cannot login to Enterprise Manger due to error with managed connections.

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Article ID: 37955

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Updated On:

Products

CA Virtual Privilege Manager CA Privileged Identity Management Endpoint (PIM) CA Privileged Access Manager (PAM)

Issue/Introduction

While accessing the CA PIM Enterprise Console the below error will appear during the login prompt. 

Error server is unavailable, No ManagedConnections available within configured blocking timeout ( 175000 [ms] ); - nested throwable: (javax.resource.ResourceException: No ManagedConnections available within configured blocking timeout ( 175000 [ms] ))

 

Environment

Privileged Identity Manager 12.8,12.9

Cause

The error is caused by reaching the maximum number of task connections to the back-end RDBMS database. 

Resolution

1. This can be cleared by a Jboss restart as that will refresh the connections.

2. If you see this error often you can increase the number of connections. In the jboss-4.2.3.GA\server\default\deploy folder edit the imtaskpersistencedb-ds.xml file. Look for the max-pool-size setting. You can increase this in small increments to avoid reaching the max connections condition.