INDETERMINATE Cluster failover status
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INDETERMINATE Cluster failover status

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Article ID: 379537

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • After upgrading VMware Cloud director (VCD) the cluster failover status is marked as INDETERMINATE
  • One/two Cloud Cell(s) node(s) exhibiting a failover status that does not match the other node(s).

Environment

VMware Cloud Director 10.x

Cause

INDETERMINATE status occurs when a Cloud Cell node is configured with a different failover status (manual or automatic).

Resolution

To align the failover status of the affected node with the rest of the cluster, use the following API calls:

  1. Create a new session to get the authorization token:

    POST https://{api_host}/api/1.0.0/sessions

    For additional information visit Post Sessions

  2. Check the postgres HA state of all nodes in the cluster using the following API and the token generated from step 1:

    GET https://{api_host}/api/1.0.0/nodes

    For additional information visit Get Nodes

  3. If the failover mode is not the same across the nodes in the cluster, proceed with the step 4 to change the failover status for the affected node.
  4. Change the failover mode on the node:

    POST https://{FQDN or IP of the node}/api/1.0.0/nodes/failover/{desired-mode}

    Valid values are:

    automatic
    manual

    For additional information visit Post Set Failover Mode

  5. Verify the status change by re-checking the cluster status as per step 2

Additional Information