INDETERMINATE Cluster failover status
search cancel

INDETERMINATE Cluster failover status

book

Article ID: 379537

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

The cluster status is marked as INDETERMINATE due to one/two Cloud Cell(s) node(s) exhibiting a failover status that does not match the other node(s).

Environment

VMware Cloud Director 10.x

Cause

INDETERMINATE status occurs when a Cloud Cell node is configured with a different failover status (manual or automatic).

Resolution

To align the failover status of the affected node with the rest of the cluster, use the following command from any Node inside your Cluster:

  1. SSH to one of the active nodes with root user.
    Use the IP or FQDN of this node to replace <node IP or FQDN> in the following steps.

  2. Create a new session to get the authorization token:
    curl -k -X POST -u root "https://<node IP or FQDN>:5480/api/1.0.0/sessions"

    Output will be of the following format:
    {
      "authToken": "<token>",
      "expires": "<timestamp>"
    }

  3. Get the information of all the nodes in the cluster using the token from step 2:
    curl -k -X GET -H "Accept: application/json" -H "Authorization: Bearer <authToken>" "https://<node IP or FQDN>:5480/api/1.0.0/nodes"

  4. Change the failover mode on the node:
    1. For automatic failover:
      curl -i -k -X POST -H "Accept: application/json" -H "Authorization: Bearer <authToken>" "https://<node IP or FQDN>:5480/api/1.0.0/nodes/failover/automatic"
    2. For manual failover:
      curl -i -k -X POST -H "Accept: application/json" -H "Authorization: Bearer <authToken>" "https://<node IP or FQDN>:5480/api/1.0.0/nodes/failover/
      manual"
  5. Verify the status change by re-checking the cluster status
    curl -k -X GET -H "Accept: application/json" -H "Authorization: Bearer <authToken>" "https://<node IP or FQDN>:5480/api/1.0.0/nodes"

Additional Information