Troubleshooting error "bucket NAME does not exist, type: BlobstoreVerifier" in Ops Manager
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Troubleshooting error "bucket NAME does not exist, type: BlobstoreVerifier" in Ops Manager

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Article ID: 379527

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Updated On:

Products

VMware Tanzu Application Service Ops Manager

Issue/Introduction

When you initiate an Apply Changes in Ops Manager, it executes several verifiers in order to validate the integrity of it configuration. One example throws a warning of this type:

 

Cause

In this case, the cause was a typo in the name of the S3 bucket listed as the storage location for droplets. A leading space was inserted in the name field at the beginning; this caused the configured bucket name not to match the actual bucket name. Carefully examining the warning as it appeared in Ops Manager reveals that the space is visible inside the initial quotes around the bucket name.

Resolution

TAS and the BOSH director both have blobstores. Check the name as it appears in the warning, and look at the manifests for TAS ("cf-xxxxxxxxxxxxxxxxxxxx") and BOSH (p-bosh-xxxxxxxxxxxxxxxxxxxx) inside the deployed_manifests_and_configs folder in the Support Bundle from Ops Manager. Check the "manifest_most_recent_xxxxxxxxxxxxxxxxxxxx.yml" for TAS and BOSH. Search within the file for the bucket name as it appears in the warning, and compare it to the name as it should be listed. If there is an error in the name, correct it in the TAS or BOSH tile in the appropriate place, save it, and run the Apply Changes again.