After Clarity upgrade, GEL connections to external Clarity databases fail with error “unsupported database”
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After Clarity upgrade, GEL connections to external Clarity databases fail with error “unsupported database”

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Article ID: 379515

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After upgrade to Clarity 16.2.0+ gel:setDataSource tag isn’t working for an external DB in GEL scripts when GEL_CONNECTION_POOL_S253100 is on

STEPS TO REPRODUCE:

  1. Connect to Clarity CSA – Database
  2. Add an external database connection
  3. Save and restart the services
  4. Create a new process with GEL script that uses gel:setDataSource to get a connection to the external DB. Ex: <gel:setDataSource dbId="TEST" var="rs"/>
  5. Example simple Process GEL:
    <gel:script xmlns:core="jelly:core" xmlns:gel="jelly:com.niku.union.gel.GELTagLibrary" xmlns:sql="jelly:sql">
    <gel:setDataSource dbId="TEST"/>
    <sql:query var="rs">select 'Connected' status from dual</sql:query>
    <gel:log>Connection Status : ${rs.rows[0].status}</gel:log>
    </gel:script>
  6. Go to Home – Reports and Jobs, Jobs
  7. Run the process we’ve created with Execute Process job
  8. Go to Administration – Processes – Initiated and check the process completion

Expected Results: The process should complete successfully and provide a successful message “Connection Status : Connected”

Actual Results: The process fails with error message:

BPM-0704: An error occurred while executing custom script: org.apache.commons.jelly.JellyTagException: null:2:35: <gel:setDataSource> <gel:setDataSource> TEST is an unsupported database

Environment

Clarity 16.2.x, 16.3.0

Cause

In version 16.2.0, GEL_CONNECTION_POOL_S253100 feature was introduced for GEL scripts.

Resolution

Workaround:

  1. Run the command to toggle off the feature:
    admin toggle-feature GEL_CONNECTION_POOL_S253100 0
  2. Clear the caches or Restart the services

This is DE155990, fixed in Clarity 16.3.1.