vCenter Server recent tasks pane shows 'Update service activation policy' and 'start service' following the upgrade of the ESXi host and vSphere Replication appliance.
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vCenter Server recent tasks pane shows 'Update service activation policy' and 'start service' following the upgrade of the ESXi host and vSphere Replication appliance.

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Article ID: 379421

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server VMware Live Recovery

Issue/Introduction

vCenter Server recent task pane shows a continuous tasks as "Start service" and "Update service activation policy" after ESXi host and vSphere Replication appliance upgrade. 

  • Start service esx.vsphere.local initiated by com.vmware.vr-sa-########@vsphere-domain.local
  • Update service activation policy esx.vsphere.local initiated by com.vmware.vr-sa-########@vsphere-domain.local

Environment

  • VMware vSphere Replication 9.0.x
  • vCenter Server 8.0.2 or later
  • ESXi 8.0.2 or later

Cause

  • This issue occurs when enhance based replication is enabled on affected ESXi host. After enabling enhanced based replication, the HMS service on vSphere Replication validates ESXi host's hbrsrv service status.
  •  hbrsrv service on should be in start state.

Resolution

To resolve follow as below:

  1. Verify that hbrsrv is running on ESXi host.
    1. Go to the vSphere Client, locate the ESXi host, navigate to the 'Configure' tab, then go to 'Services'.
    2. Look for the service hbrsrv in the list and check if its status is Running.
    3. If it is in stopped state, please start the service.

  2. If the alerts don't stop after starting hbrsrv service, apply the workaround as below;
    1. Take snapshot of vSphere Replication appliance, stop and start the hms service in VAMI page (port 5480) of vSphere Replication appliance. ESXi host's hbrsrv service will be started automatically after HMS service restart. Please refer to below screenshot.
    2. "start service" and "update service on activation policy" task should now stop. 

  3. Please reconfigure vSphere Replication appliance, if tasks are still there after following step 1 and 2. See, Reconfigure General vSphere Replication Settings


If you are still getting repeated same tasks after following above steps, please raise a SR with Broadcom technical support. See, Creating and managing Broadcom support request (SR) cases

Additional Information