A valid license was added to a Symantec Protection Engine Linux server but it is was not being recognized as valid
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A valid license was added to a Symantec Protection Engine Linux server but it is was not being recognized as valid

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Article ID: 379403

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Updated On:

Products

Protection Engine for Cloud Services

Issue/Introduction

A new license file was downloaded and, since no SPE console was being used, it was manually copied into /opt/Symantec/Licenses

  • The services were restarted:  /etc/init.d/symcscan restart
  • The report.xml file was examined and, in the <licenseinformation> section all elements showed  status="No-Valid-License"
  • The expiration date in the actual license file was two years later than the current date

Environment

Protection Engine 9.2

Cause

The account the symcscan service was configured to start with did not have read, or any permissions to /opt/Symantec/Licenses

Note: To verify the name of the account the service is starting with run the following command:    cat /etc/init.d/symcscan | grep User=

Resolution

The problem resolved after granting permissions for the User account the service starts-- allowing at least "Read" permissions to /opt/Symantec/Licenses


Then restarting the service again.  /etc/init.d/symcscan restart