vCenter having intermittent "Incomplete collection" error
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vCenter having intermittent "Incomplete collection" error

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Article ID: 379370

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

vCenter having intermittent "Incomplete collection" error, no recent logs in vccol*.log

Environment

Usage Meter 4.8

Cause

Issue with dss.hash file 

Resolution

  1. Login in to Usage Meter appliance as usagemeter user

  2. Navigate to /opt/vmware/cloudusagemetering/var/dss/hash

    cd /opt/vmware/cloudusagemetering/var/dss/hash

  3. Rename the file: dss.hash

    mv dss.hash dss.hash.bak

  4. Restart the services:

    cd /opt/vmware/cloudusagemetering
    ./scripts/stop.sh All
    ./scripts/start.sh All

  5. Wait a couple of minutes and check the status

    ./scripts/status.sh

  6. Confirm that the file: dss.hash is recreated in: /opt/vmware/cloudusagemetering/var/dss/hash 
  7. vCenter collection should be fixed