Vcenter Appliance (VCSA) Loses Network Connectivity During Patching from Version 7.0 U3o to 7.0 U3s Due to Secondary NIC
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Vcenter Appliance (VCSA) Loses Network Connectivity During Patching from Version 7.0 U3o to 7.0 U3s Due to Secondary NIC

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Article ID: 379356

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • VCSA patching was attempted from version 7.0 U3o to 7.0 U3s.
  • vCenter was loosing the network during the installation phase of RPMs.
  • Unable to restore vCenter network connectivity.

Environment

vCenter Patch from 7.0 U3o to 7.0 U3s

Cause

This behavior can be observed when vCenter is configured with two vNICs. For example, one for the management network and another as a backup network adapter. The secondary vNIC causes network routing and gateway conflicts during the patch process. As network services restart, VCSA may switch to the secondary vNIC, leading to a loss of connectivity if it is not properly configured.

Resolution

Remove the secondary vNIC from the vCenter Server Appliance VM before starting the patch resolves this issue.

    1. Log into vSphere.
    2. Power off the vCenter Server Appliance VM. 
    3. Right-click the vCenter Server Appliance VM. 
    4. Mouse over the secondary vNIC (the one that is not using the management address) and click the X on the right-hand side of the Edit Sittings window on the vNIC to remove it. 
      • If you are unsure which vNIC is tied to the IP address, please either console or SSH into the vCenter and run ifconfig to see which vNIC MAC address is tied to the IP. You can correlate this MAC address within the Edit Settings pane of the VM. 
    5. Save your changes. 
    6. Power up the vCenter Server Appliance VM and re-try the upgrade.