NSX "Upgrade in progress" notification when it has already completed
search cancel

NSX "Upgrade in progress" notification when it has already completed

book

Article ID: 379349

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • The NSX has upgrade has been completed successfully
  • Status PAUSED is found in logs  /var/log/upgrade-coordinator/upgrade-coordinator.log:
    2024-09-25T11:51:53.563Z  INFO http-nio-127.0.0.1-7442-exec-1 UpgradeCoordinatorFacadeImpl 3408 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="upgrade-coordinator"] Group:  ########-####-####-####-###########:domain-####, status: PAUSED, unit count: 6, failed count: 0, % complete: 83.0
    When reviewing NSX-UI and System --> Fabric --> Hosts there is a Host that is reported as DOWN
  • A notification indicating "Upgrade in progress" was generated Current version and target version are the same

Environment

VMware NSX

Cause

Host upgrade status regresses due to failed post-upgrade checks after upgrade-coordinator JVM is restarted.

 

Resolution

This issue is resolved in VMware NSX 4.1.2.5, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

Workaround:

  • Log in to the NSX Manager appliance UI -->  https://NSX_FQDN  and navigate to System --> Fabric --> Hosts and ensure that ALL hosts are up
  • Log into the  ALL  Managers appliance UI  and navigate to   System --> Upgrade and refresh the screen the correct information regarding the update should be displayed 

Additional Information

VMware NSX