Upgrade issue due to unsupported Dell ESA Management Pack - "Describe Operations failed"
search cancel

Upgrade issue due to unsupported Dell ESA Management Pack - "Describe Operations failed"

book

Article ID: 379331

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

After successful upgrade of Aria Operations and Cloud Proxies.  Cloud Proxies are showing "Going Online" status.  Adapters are not collecting.

If adapters are changed to Default collectors, data collection is also failing.

If cluster is taken offline, then try to bring it back online, it will stay in "Going Online" state.

Environment

Aria Operations 8.18.1

Cause

Deprecated and unsupported Dell Enterprise Storage Array (ESA) Management Pack  is causing Describe Operations to fail.

The following error is recorded in the Aria Operations' collector.log file:

2024-10-03T12:03:20,464+0000 INFORMATION [Heartbeat]  com.integrien.alive.collector.HeartbeatThread.hbFailLogger - vRealize Ops controller did not successfully respond to collector id request. Response code = -8 Message = Controller is not ready. Check adapters describe status.
2024-10-03T12:03:50,466+0000 INFO  [Heartbeat]  com.integrien.alive.collector.HeartbeatThread.doHeartBeat -  <- HB response : Controller is not ready. Check adapters describe status.

On Aria Operations UI, Redescribe shows the following Error:

When try to perform a "Redescribe" operations, the following error is recorded in Analytic Log:

ERROR [DistTaskDistributedTaskDescribe] com.vmware.vcops.controller.data.utils.AdapterDescribeManager.describeAdapters - Describe failed java.lang.RuntimeException: Describe would remove resources, so we are failing to describe. Problematic resource kind is EMC:Disk. Please mark this kind as deleted to remove with the child resource or repair the adapter and try again!

Resolution

Delete the Dell ESA Management Pack from the Repository:

  • Log into the Product UI.
  • Go to Administration/Integrations
  • Click on Repository Tab
  • Locate the Dell ESA Management Pack and click Delete.

Once the Management Pack is deleted, go to Global Setting/Redescribe.  Click on "Redescribe" to perform another Describe Operations. Upon successful redescribe, all Cloud Proxies will be showing as Online.  Data Collection will be working properly.