SDM stops processing PAM calls randomly
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SDM stops processing PAM calls randomly

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Article ID: 379285

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Process Automation Base

Issue/Introduction

SDM Stopped making calls to ITPAM. However, after some time (minutes or hours) it will resume and will continue processing processes through pdm_rpc. There is no restart or crash of the pdm_rpc process. 

Environment

SDM 17.4 RU1 and later

PAM 4.4 CP2 and later

Cause

The animator process fetches all the anima objects from the backlog every 30 minutes (1800 seconds). This is the default interval. Initially, the anima object is added to the domset. When there are multiple requests at a time it adds all anima events to the backlog. And then again fetching together at some interval and firing the actions.

Resolution

1. Set the animator process to fetch every 10 minutes. This can be configured using the NX variable NX_ANI_INTERVAL.

So enable this configuration parameter as 600 and verify the issue. 

Use the below commands to enable the NX variable. After executing the commands check the NX.env file to make sure NX_ANI_INTERVAL is added with the value 600.

pdm_options_mgr -c -s ANI_INTERVAL -v "600" -a pdm_option.inst

pdm_options_mgr -c -s ANI_INTERVAL -v "600" -a pdm_option.inst -t

2. Add a 5-second delay to the event(s) (Administration > Events and Macros > Events > Click on the Event > Set the Delay time to 5 seconds (00:00:05)

3. Restart SDM services for the changes of step 1 to take effect.