DB exception for user and duplicate entry error in VIP Authentication Hub
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DB exception for user and duplicate entry error in VIP Authentication Hub

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Article ID: 379276

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Updated On:

Products

VIP Authentication Hub

Issue/Introduction


Running VIP Authentication Hub, users can't login anymore, and the browser receives a DB error.

The Kibana logs show:

(conn=<number>) Duplicate entry '<uid_number>-<ldap_store>:3394:<name>-<random_number>' for key 'T_USER_UNIVERSAL_ID_IDENTITY_SOURCE_ID'

 

Cause


The T_USER table in VIP Authentication Hub database has the following UNIQUE KEY constraint:

UNIQUE KEY 'T_USER_UNIVERSAL_ID_IDENTITY_SOURCE_ID' ('UNIVERSAL_ID','IDENTITY_SOURCE_ID','TENANT_ID')

The 'Duplicate entry' error message shown above:

(conn=<number>) Duplicate entry '<uid_number>-<ldap_store>:3394:<name>-<random_number>' for key 'T_USER_UNIVERSAL_ID_IDENTITY_SOURCE_ID'

indicates that VIP Authentication Hub was trying to insert a record into T_USER table, but the values for the UNIVERSAL_ID, IDENTITY_SOURCE_ID, and TENANT_ID columns are not unique.

This violates the above UNIQUE KEY constraint defined on those columns, which ensures that no two records can have the same combination of these three values.

VIP Authentication Hub prevents duplicate identity in T_USER table so user credentials, Trusted Device Information, Risks Information are correlated to a correct Identity.

 

Resolution


In the Administration Console, query for local user account management --> search users by Filter --> https://{{sspHost}}/{{apiPathTenant}}/admin/v1/Users?filter=user_universalId eq <uid_number>

and see the user duplicated profiles.

Deleted the other profiles to keep only one, to solve this issue.