NSX Upgrade Pre-check fails with the error message "Failed to execute Check for NSX Application Platform version for upgrade."
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NSX Upgrade Pre-check fails with the error message "Failed to execute Check for NSX Application Platform version for upgrade."

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Article ID: 379259

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Updated On:

Products

VMware NSX

Issue/Introduction

  • This can be observed when upgrading from a 3.2 or higher version to any version.

  • Legacy NSX Intelligence Appliance (VM-based) are present in the environment.

  • During the upgrade of NSX Manager, an error message is displayed stating that NAPP needs to be upgraded first, even though NAPP is not installed in the environment. This issue prevents the upgrade process from proceeding.

  • Error message observed under "Edges" Pre-check:
    Failed to execute Check for NSX Application Platform version for upgrade. [UC] Error in rest call. url=/napp/api/v1/platform/monitor/platform/status , method= GET ,response= Unknown Error occurred , error= I/O error on GET request for "https://<nsx-manager-virtual-ip>:443/napp/api/v1/platform/monitor/platform/status": Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty; nested exception is javax.net.ssl.SSLException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty .

Environment

VMware NSX-T Data Center 3.x

VMware NSX 4.x

 

Cause

The root cause of the issue is that the NSX Manager is still trying to check the status of the Intelligence Feature, which might be no longer used, and is causing the upgrade process to fail.

The presence of the legacy NSX Intelligence Appliance (VM-based) is triggering this behavior.




 

Resolution

This is a condition that may occur in a VMware NSX environment.

Workaround

  • Delete the NSX Intelligence Appliance from the Appliances tab in the NSX Manager that is no longer in use.
  • Once the appliance is deleted, the pre-checks should succeed, and the upgrade process can proceed. If the Pre-checks still fail please open a support case with Broadcom Support and refer to this KB article.

    For more information, see Creating and managing Broadcom support cases.

Additional Information

If the environment has a working NSX Intelligence VM-based appliance, it is recommended to have it migrated to the NSX Application Platform based vertical. More information about this can be found in the below document.