The Messaging Gateway (SMG) Message Audit Logs show the following status in the DKIM results validation tab:
temperror (key unavailable)
Cause
Messaging Gateway is unable to retrieve the recipient DKIM records in the DNS. This may be due to one or more of the following:
The records do not exist in the DNS
The configured DNS servers in Administration > Configuration > host > DNS / Time are either inaccessible or not responding as expected
Messaging Gateway has been configured to use one or more public, rate limited DNS servers
DNS servers are responding slowly to queries
Resolution
Confirm that the DNS servers configured in Administration > Configuration > host > DNS / Time are responding as expected
Log into the Messaging Gateway command line as admin
Query the configured nameserver directly for a known good domain with the correct selector by appending the nameserver IP to the nslookup command. For example: