Smart Response rules are empty, incident menus are frozen after upgrade to DLP 16.0.2
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Smart Response rules are empty, incident menus are frozen after upgrade to DLP 16.0.2

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Article ID: 379236

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Updated On:

Products

Data Loss Prevention Core Package

Issue/Introduction

After upgrade to DLP 16.0.2 "RU2" Smart response rules appear to be broken, and otherwise comes up blank.

When clicking any pull downs in an incident with a smart response rule nothing happens.

Upon further investigation it is found that this issue does not present itself when using the built in Administrator account.

 

Although tomcat logs show no corresponding errors you can validate the issue by using the browsers built in web developer tool and viewing the problem incidents with a problem account.

you will see the following error:

ERROR TypeError: Cannot read properties of undefined (reading 'name')   main.js:19  
     at Fe (413.js:19:41932)

Environment

DLP 16.0.2

Cause

This has been found to be due to a limitation in the RBAC service role system, and a conflict from the old system to the new one.

Resolution

This functionality has been fixed in DLP16.1 due for release at the end of October 2024


In the meantime you can use this work around.


While logged on as the role\user experiencing the issue, navigate to any incidents report that the user can execute and that contains incident(s):




https://enforce.company.com/ProtectManager/enforce/ui/incident/list/2512



Note the report ID from the URL (2512 in this example) and manually navigate to the corresponding legacy 15.x UI for that report:




https://enforce.company.com/ProtectManager/GetReport.do?reportID=2512



Then load the (legacy) incident snapshot page for any incident from the report, and click on the 'Customize Layout' button towards the top right side of that UI page, to access the Incident Snapshot Configuration page for the user:


 


The smart response rule(s) displayed - available for display order configuration by the end-user - should be in line with the RBAC limitation. Blank out all of them (choose blank in each drop down list box) as to void the display configuration for these rules for the end-user. We want to void that configuration attached to the end-user because the configuration set up for a particular role might conflict with another role used by that very same end-user, hence voiding that configuration is a must to make sure the end-user will not see the defect regardless of the role they are using. Hit the Save button to confirm the configuration. This should immediately fix the problem for the affected end-user:


This workaround must be executed for each role/end-user affected by the problem.

Additional Information

Please note: if manual changes are made to the order of Smart Response Rules, it’ll reintroduce the issue and the same steps must be retaken to fix it again.