DSM Domain Installation error - could not contact database 'mdb' on server
search cancel

DSM Domain Installation error - could not contact database 'mdb' on server

book

Article ID: 379228

calendar_today

Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

During Installation of a new Domain Manager validation of mdb settings return this error :

CA Client Automation Setup could not validate the given settings.
Could not contact database 'mdb' on server
(instance _INSTANCE_)

To achieve this:
check server and instance names.
For details see log file TRC_Inst2_ITRM.log.

 

In %TEMP%\DSMSetup.log

1: 10-8-2024 - 19:13:24 - INFO    - File: CAUniITRM_DataBase.rul    - Line:  2746 -  
1: 10-8-2024 - 19:13:24 - INFO    - File: CAUniITRM_DataBase.rul    - Line:  2749 - launch ciCheckInit(SQLServer,sqlserver) 
1: 10-8-2024 - 19:13:24 - WARNING - File: CAUniITRM_DataBase.rul    - Line:  2760 - Calling ciCheckIsValidInstanceName with:  
1: 10-8-2024 - 19:13:24 - INFO    - File: CAUniITRM_DataBase.rul    - Line:  2824 - Launch ciCheckFull (<DBSERVERNAME>, , 1433, mdb, ca_itrm, xxx, C:\DVD0000000004341\WindowsProductFiles_x86, , xxx)
1: 10-8-2024 - 19:13:24 - INFO    - File: CAUniITRM_DataBase.rul    - Line:  2828 - ciCheckFull (<DBSERVERNAME>, , 1433, mdb, ca_itrm, xxx, C:\DVD0000000004341\WindowsProductFiles_x86) returned: -3002
1: 10-8-2024 - 19:13:24 - WARNING - File: CAUniITRM_DataBase.rul    - Line:  2875 - ciCheckFull returned: -3002 
1: 10-8-2024 - 19:13:24 - INFO    - File: CAUniITRM_DataBase.rul    - Line:  2878 - Launch ciCheck.ciGetErrorStr (-3002, enu) 
1: 10-8-2024 - 19:13:24 - INFO    - File: CAUniITRM_Setup.rul       - Line: 13428 - String('ID_MSG_CICHECK_ERROR_1') = '[1] Setup could not validate the given settings.

[2]' 
1: 10-8-2024 - 19:13:24 - INFO    - File: CAUniITRM_Setup.rul       - Line: 13428 - String('ID_MSG_CHANGE_OR_CANCEL') = 'Please change your settings to install or cancel setup.' 
1: 10-8-2024 - 19:25:49 - INFO    - File: CAUniITRM_DataBase.rul    - Line:  2976 - Database_Test_DB_Connection Exit 

 

And in %TEMP%\TRC_Inst2_ITRM.log

10/08/24 19:13:24.0754|5784:|CiCheckDBMsSQL::checkDBConnection: Start
10/08/24 19:13:24.0754|5784:|    Checking trusted connection
10/08/24 19:13:24.0754|5784:|    used server name <DBSERVERNAME>
10/08/24 19:13:24.0769|5784:|    MsSQL trusted connection <FAILED><-2>
10/08/24 19:13:24.0769|5784:|CiCheckDBMsSQL::getLastDBError: Start
10/08/24 19:13:24.0769|5784:|CiCheckDBMsSQL::getLastDBError: End
10/08/24 19:13:24.0769|5784:|    error message <   Description   : Provider cannot be found. It may not be properly installed.    Source        : ADODB.Connection    Error Message : Unknown error 0x800A0E7A >

Environment

Client Automation 14.5.
Microsoft SQL Server 2019 or 2022

Cause

Microsoft SQL Server 2012 Native Client is not installed on the Server.
Setup.exe is looking for file sqlncli11.dll or sqlncli10.dll for database connection.

Resolution

Install "Microsoft SQL Server 2012 Native Client".

  1. Download the file x64 file sqlncli.msi from here :

    Download Microsoft® SQL Server® 2012 Native Client – QFE from Official Microsoft Download Center




  2. Execute sqlncli.msi and install "Client Components"


Additional Information

Next Release of Client Automation (ETA mid 2025) will use Microsoft OLE DB Driver for SQL Server and no more "Microsoft SQL Server 2012 Native Client"