failing to access Monitoring Module after installation: APMIA + API Gateway integration
search cancel

failing to access Monitoring Module after installation: APMIA + API Gateway integration

book

Article ID: 379222

calendar_today

Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

cannot see API Gateway's metrics from APM Console 

Environment

API Gateway 11.x

APM Server 9.4

Cause

documentation configuration 

Resolution

It seems the installation of API gateway package and and the API configuration from gateway side  was not correct , Yesterdays webex we did re-installation of the packages  and configured some apis ,post that the  Service node reported  under the APM metrics.

documentation from API Gateway was updated to finish the config correctly.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/precision-api-monitoring/3-4/release-notes.html

  • EPAgent has reached End-of-Service in its product support life cycle. Users using on-prem APM server can now download the API Gateway Infrastructure Agent and are recommended to use SaaS installation for API monitoring. For further details, see SaaS installation.
refers to :
 
We did several sessions with customer and showed details about how to install and how to configure the " API Gateway Infrastructure Agent"