WARNING - ServiceDeskIntegrationManager : Tomcat not started yet
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WARNING - ServiceDeskIntegrationManager : Tomcat not started yet

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Article ID: 379191

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Updated On:

Products

DX NetOps

Issue/Introduction

This warning is being displayed on each 5 seconds in tomcat logs, causing the log file to grow up and potentially filling the disk space:

2024-09-27 14:57:19,216 [Thread-38] WARN  com.aprisma.errorlog - WARNING - ServiceDeskIntegrationManager : Tomcat not started yet
2024-09-27 14:57:24,217 [Thread-38] WARN  com.aprisma.errorlog - WARNING - ServiceDeskIntegrationManager : Tomcat not started yet
2024-09-27 14:57:29,217 [Thread-38] WARN  com.aprisma.errorlog - WARNING - ServiceDeskIntegrationManager : Tomcat not started yet
2024-09-27 14:57:34,217 [Thread-38] WARN  com.aprisma.errorlog - WARNING - ServiceDeskIntegrationManager : Tomcat not started yet

Environment

Spectrum 23.3.7 and higher versions.

Cause

Missing line in $SPECROOT/tomcat/conf/server.xml file :

<Listener className="com.aprisma.spectrum.app.web.util.TomcatStartupListener"></Listener>

Actually server.xml file should have TomcatStartupListener configured otherwise this issue is expected. The TomcatStartupListener will set the tomcat_started parameter which is then used in other parts of the code to identify that the tomcat server has been started. 

If this listener is disabled then this tomcat_started parameter never gets set and the parts of the code does not identify tomcat startup and hence they result in continous logging saying Tomcat not started yet.

Resolution


Please ensure that the related line is available in the $SPECROOT/tomcat/conf/server.xml file:



If that line is not present, insert it and bounce the tomcat service.