Edge Events shows mgd error 'EOF occurred in violation of protocol (_ssl.c:1129)' with SSLError
search cancel

Edge Events shows mgd error 'EOF occurred in violation of protocol (_ssl.c:1129)' with SSLError

book

Article ID: 379167

calendar_today

Updated On:

Products

VMware VeloCloud SD-WAN

Issue/Introduction

Edge fails to exchange successful heartbeat with Orchestrator. 

Customer receives Edge Down and then Edge Up events. This may cause alerts being triggered to customers.

In the edge Event logs we see below error

[heartbeat (18527:Heartbeat:18957)] Heartbeat invocation failed: SSLError(MaxRetryError("HTTPSConnectionPool(host='xxxxx.domain.net', port=443): Max retries exceeded with url: /upload/ (Caused by SSLError(SSLEOFError(8, 'EOF occurred in violation of protocol (_ssl.c:1129)')))"))

Environment

Velocloud Orchestrator, Velocloud Edge, SDWAN

Cause

Possible causes for the error and things to be checked to narrow down the issue

 

Server Issues: The server you're trying to connect to may be down, misconfigured, or not supporting the SSL/TLS version you are using.

Checks to be done: Check the Orchestrator status. If Orchestrator is undergoing any maintenance activity etc.

Protocol Mismatch: The client and server may not agree on the SSL/TLS protocol version or cipher suites. Make sure both sides support the same versions.

Checks to be done: Check if there is any change in the SSL/TSL packages on the Of orchestrator or the VM in case of Virtual edges.

Expired or Invalid Certificates: If the server's SSL certificate is expired or not properly configured, this could lead to connection issues.

Checks to be done: Checks the validity of the certificates of the edges and the Orchestrator

Firewall/Proxy: Sometimes firewalls or proxy servers can interfere with SSL/TLS connections.

Checks to be done: If there are any firewall which inspects SSL connections and exchanges intermediate certificates.

Network Issues: There might be a temporary network disruption or a problem with your internet connection.

Checks to be done: Check for internet stability. Check the tunnels towards the Primary gateway is stable and lossless. The mgd traffic should be stable not flapping between gateway and direct.

Resolution

Perform the checks as mentioned above.

If still the errors are seen, please open a case with SDWAN Support Team.

Global Support Phone Numbers: Support Phone numbers