Another user is already identified by the Single Sign On User Attributes that you specified when trying to create a user with SAML enabled
search cancel

Another user is already identified by the Single Sign On User Attributes that you specified when trying to create a user with SAML enabled

book

Article ID: 379157

calendar_today

Updated On:

Products

Data Loss Prevention Core Package Data Loss Prevention Enforce

Issue/Introduction

When trying to create a local user in the Enforce Console it fails with an error "Another user '<user name>' is already identified by the Single Sign On User Attributes that you specified. 

Cause

With SAML integration enabled the SSO User Attributes must be unique for every created user. The attributes are configured per user basis in the user configuration "Single Sign On Mapping" section. By default it contains the e-mail address but it may differ based on the integrated SAML service requirements. The error message that is displayed during the user creation points to the user name that already has the same information in the Single Sign On Mapping field. 

 

 

Resolution

It is necessary to enter unique information into the the Single Sign On Mapping field/s to successfully create users with SAML integration enabled. If the user will not be using SAML integration to login, which should be done for API users, then the field can be left blank and it will also satisfy the requirements.