Aria Operations admin account getting locked by Aria Operations for Logs Integration
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Aria Operations admin account getting locked by Aria Operations for Logs Integration

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Article ID: 379156

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

While trying to access Aria Operations UI using the default local admin account, it gives the error "Incorrect Username or Password".

This occurs when Aria Operations for Logs integration is configured with the default local admin account and the incorrect password combinations are provided.

Environment

Aria Operations 8.x

Cause

This is the expected error message "Incorrect Username or Password" when the admin account is locked due to multiple login failures.

Resolution

Steps To update Aria Operations Integration:

    1. Update the password used for Aria Operations Integration:
      • Unlock the admin account Aria Operations as per kb Log in to Admin and Product UI as admin fails in Aria Operations
      • Sign into Aria Operations for Logs UI
      • Update the password under Integration > VMware Aria Operations 
      • Click on the edit icon resembles clipboard with pencil
      • Update the password to the current password for Aria Operations
      • Save the changes
      • Unlock the admin account Aria Operations again
    2. Change the Account used for Aria Operations Integration.
      • Go to your Aria Operations for Logs URL and add /internal/config to the end. (IE: http://<AriaOpsforLogsFQDN>/internal/config)
      • Then do a search on the page for "vcops" and look for the user account it's using to integrate into Aria Operations
      • Change that to anything else. It does not need to be a real account.
      • Then scroll down and click "Save." This should also stop Aria Operations from locking out the Admin account.
      • This only needs to be done once. 
    3. To change the Account used for Aria Operations integration manually in Photon, follow the steps below:

      • SSH into each node and run the command: vi $(ls /storage/core/loginsight/config/loginsight-config.xml#* | tail -n1) 
      • type the "/" key to Search for the term "vcops" and then look for the username it's using to integrate into Aria Operations, hit the "Insert" key and change that to anything else. 
      • type ":wq" to Save and exit,
      • then repeat all nodes in the cluster.
      • restart services
        • service loginsight restart

If Test Connection fails even after updating the password please:

  1.  Check what IP address is causing the lockouts in vRealize/Aria Operations admin account getting locked even after password reset if the IP address is Aria Operations for logs please delete the integration for Aria Operations in Aria Operations for Logs and reboot the offending Aria Operations for Logs node. 
  2. Unlock the Admin account as per kb Log in to Admin and Product UI as admin fails in Aria Operations
  3. Reconfigure the Aria Operations integration in Aria Operations for Logs 

 

Additional Information