SNMP polls successful from OneClick but fails from MIB Tools
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SNMP polls successful from OneClick but fails from MIB Tools

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Article ID: 378972

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When polling a model in Spectrum OneClick, the poll is successful. However, when querying the mib in MIB Tools for the same device, the query fails.

Environment

Version: Any
Component: MIB Tools

Cause

We started a tcpdump on the SpectroSERVER sniffing the ip address of the device in question and then ran the query in MIB Tools.

The query showed the device responding with "noSuchObject" to the snmp requests.

The following is a snippet from the tcpdump:

    data: get-response (2)
        get-response
            request-id: 44028064
            error-status: noError (0)
            error-index: 0
            variable-bindings: 9 items
                1.3.6.1.2.1.1.1.0: noSuchObject
                    Object Name: 1.3.6.1.2.1.1.1.0 (iso.3.6.1.2.1.1.1.0)
                    noSuchObject
                        [Expert Info (Note/Response): noSuchObject]
                            [noSuchObject]
                            [Severity level: Note]
                            [Group: Response]
                1.3.6.1.2.1.2.1.0: noSuchObject

Running the same queries on other devices do not show this issue.

Resolution

The "noSuchObject" error in an SNMP get request means that the specified SNMP object could not be found. This can be caused by:


      • A changed OID
      • Network connection problems
      • Incorrect SNMP settings, such as the port, version, community string, or authentication credentials
      • The target device does not have a counter for the OID
      • The variable does not have an OBJECT IDENTIFIER prefix that matches the prefix of any variable accessible by the request
      • The MIB object queried is not present in the MIB 

This is an issue at the device responding to snmp.