OVA Import/Export Fails in VMware Cloud Director
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OVA Import/Export Fails in VMware Cloud Director

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Article ID: 378946

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • OVF/media imports to VMware Cloud Director Catalog stuck at "1%"

When trying to upload OVF or Media (ISO) to VMware Cloud Director catalog, the status of the tasks never moves past "1%".

Uploading directly to the cell via the API works as expected.

Transfer share has sufficient space available.

From the logs, the upload task does not seem to go beyond a certain limit:

Resource file not fully transferred yet (262,144,000/18,598,195,200) for transfer session 160xxxe-8xxa-44xx-8xx4-dxxxfcfxxxx7 

  • Downloading OVA from VCD fails at 99% with an error indicating "check internet connection."

Environment

VMware Cloud Director 10.5.x and above.

Cause

This usually occurs when there are LB/Firewall restrictions which does not allow the transfer to complete or pass beyond a certain limit.

Same can be confirmed from the vcloud-container-debug.log on the Vmware Cloud Director Cell:

2xxx-xx-xx 09:57:05,911 | SECURITY | pool-jetty-4684   | ImageTransferServer  | Transfer session: 7xxxxxxa-dxx9-4xxa-bxxa-5xxxxxxxxxx9. Validated transfer request for resource file: bxxxxxxb-cxxc-4xx2-bxx4-5xxxxxxxxxxc, 'file', (0 / 18,598,195,200 bytes transferred) 

2xxx-xx-xx 09:59:25,266 | SECURITY | pool-jetty-7280   | ImageTransferServer  | Transfer session: 7xxxxxxa-dxx9-4xxa-bxxa-5xxxxxxxxxx9. Validated transfer request for resource file: bxxxxxxb-cxxc-4xx2-bxx4-5xxxxxxxxxxc, 'file', (8,965,324,800 / 18,598,195,200 bytes transferred) 


In the above example, the upload stops just after 2 minutes when the task is initiated.

Resolution

This issue is outside the scope of VMware Cloud Director. We recommend consulting your networking team to review the configurations or settings on your physical network, as a load balancer or firewall may be preventing the import and export from completing successfully.