OVA Import/Export Fails in VMware Cloud Director
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OVA Import/Export Fails in VMware Cloud Director

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Article ID: 378946

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • OVF/media imports to VMware Cloud Director Catalog stuck at "1%".
  • When trying to upload OVF or Media (ISO) to VMware Cloud Director catalog, the status of the tasks never moves past "1%".
  • Uploading directly to the cell via the API works as expected.
  • Transfer share has sufficient space available.
  • From the logs, the upload task does not seem to go beyond a certain limit:

Resource file not fully transferred yet (262,144,000/18,598,195,200) for transfer session 160####a-8##a-4##4-8##4-d##########7 

  • Downloading OVA from VCD fails at 99% with an error indicating "check internet connection.
  • Same can be confirmed from the vcloud-container-debug.log on the Cell:

    | SECURITY | pool-jetty-4684   | ImageTransferServer  | Transfer session: 160####a-8##a-4##4-8##4-d##########7. Validated transfer request for resource file: b########b-c##c-4##2-b##4-5##########c, 'file', (0 / 18,598,195,200 bytes transferred) 

    | SECURITY | pool-jetty-7280   | ImageTransferServer  | Transfer session: 160####a-8##a-4##4-8##4-d##########7. Validated transfer request for resource file: b########b-c##c-4##2-b##4-5##########c, 'file', (8,965,324,800 / 18,598,195,200 bytes transferred) 

Environment

  • VMware Cloud Director 10.5.x
  • VMware Cloud Director 10.6.x

Cause

This usually occurs when there are LB/Firewall restrictions which does not allow the transfer to complete or pass beyond a certain limit.

Resolution

This issue is outside the scope of VMware Cloud Director. We recommend consulting your networking team to review the configurations or settings on your physical network, as a load balancer or firewall may be preventing the import and export from completing successfully.

As a workaround, upload the media ISO directly from a Cell UI.