Remote RMS agentless metrics aren't working if "Forms" and "Windows" authentication are enabled
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Remote RMS agentless metrics aren't working if "Forms" and "Windows" authentication are enabled

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Article ID: 378883

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Updated On:

Products

IT Management Suite

Issue/Introduction

The remote RMS (Remote Monitoring Server) returns no agent-less metrics.

Note:
Local RMS is still able to perform agent-less monitoring and metrics are available. Therefore, the only machines possibly affected by this issue are remote RMS instances. 

Environment

ITMS 8.7, 8.7.1, 8.7.2

Cause

Enabling "Forms" and "Windows" authentication causes this issue.

00002944    7:55:26 AM    [340]     <form name="formLoginUser" method="post" action="./LogInUser.aspx?ReturnUrl=%2faltiris%2fPluggableProtocols%2fNSAccess%2fNSAccess.aspx" id="formLoginUser">     
00002945    7:55:26 AM    [340] <input type="hidden" name="_VIEWSTATE" id="_VIEWSTATE" 

00003124    7:55:26 AM    [340] PPA:  [Debug] CallRemoteNSAccess:> success = 1, returned encoded/decoded strings are 13540/0 char(s) long    
00003125    7:55:26 AM    [340] PPA:  [Info] GetDevIPAddrList:> got no data from the server for device {757FD6DB-CFCC-4CF2-84D4-767C44244226}    

Resolution

This issue has been resolved in our ITMS 8.7.3 Release.

Workaround:

  1. On your (ITMS 8.7.2) SMP Server, open IIS Manager 
  2. Go to  "Default Web Site\Altiris\PluggableProtocols\NSAccess" webapp
  3. Open "Authentication"



  4. Set to Disable  "Forms Authentication"

 

After this, all remote "Remote Monitoring Server" servers will be able to start an agent-less monitoring and get agent-less metrics values.