Newly created NSX Segment is not visible in the vCenter Network Inventory
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Newly created NSX Segment is not visible in the vCenter Network Inventory

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Article ID: 378847

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Creating a new NSX Segment via the NSX UI does not reflect in the vCenter Inventory.
  • It is reflected in the NSX UI and the status shows "success".

Environment

  • All NSX versions.

Cause

 

  • The NSX Segment is pushed to the vCenter via cm-inventory updates.
  • If the vCenter connectivity is down, the newly created segment updates will not be pushed to the vCenter. 
  • While navigating to System > Fabric > Compute Managers via the NSX UI, the following is seen :

 

Resolution

 

      • In the above scenario, the vCenter's SSL Certificates were replaced post which the issue had occurred.
      • Due to the new thumbprint not matching the current value, the Compute Manager's state was down.
      • Edit the above Compute Manager via the Edit button and update the correct thumbprint and click on Save.
      • The thumbprint can be retrieved by using the following command : openssl x509 -in /etc/vmware-vpx/ssl/rui.crt -fingerprint -sha256 -noout
      • Post that, the Compute Manager's status showed up as "Up" and the newly created segment was visible on the vCenter's Network Inventory.