Problems starting services after upgrade
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Problems starting services after upgrade

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Article ID: 378703

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Updated On:

Products

CA Service Management - Asset Portfolio Management ASSET PORTFOLIO MGMT- SERVER CA IT Asset Manager CA IT Asset Manager Asset Portfolio Management

Issue/Introduction

After upgrading ITAM, the services will not start.

Environment

IT Asset Manager v17.x

Cause

When reviewing the configuration files we found many had not been successfully updated during the installation. In particular, the CA.Common.LoadConfigurationAttributes.dll.config file should contain database connection information in the first few lines of the file.  For example:

<?xml version="1.0"?>
<configuration>
  <appSettings>
    <!--Setting the type of Database-->
    <add key="DatabaseType" value=""/>   
    <add key="IsSql2000" value="False"/>
    <!-- True for SQL Server 2000; False otherwise -->
    <add key="SqlServerVersion" value=""/>
    <!--Setting Login Information for DB-->
    <add key="UserID" value=""/>
    <add key="Password" value=""/>
    <!--Update HostName for Sql Connections and ServiceName for Oracle Connections-->
    <add key="HostName" value=""/>
    <add key="ServiceName" value=""/>
    <!--Only need for Sql-->
    <add key="DatabaseName" value=""/>
    <!--Enter Database Owner (dbo for SQL Server and mdbadmin for Oracle) -->
    <add key="DatabaseOwner" value=""/>

All the highlighted rows above should contain values and not empty double-quotes ("").  There are copies of this file in the following folders:

C:\Program Files (x86)\CA\ITAM\Application Server\bin
C:\Program Files (x86)\CA\ITAM\Data Importer
C:\Program Files (x86)\CA\ITAM\Data Importer Engine
C:\Program Files (x86)\CA\ITAM\Event Service
C:\Program Files (x86)\CA\ITAM\Export Service
C:\Program Files (x86)\CA\ITAM\Hardware Engine
C:\Program Files (x86)\CA\ITAM\Import Driver
C:\Program Files (x86)\CA\ITAM\Import Processor
C:\Program Files (x86)\CA\ITAM\Import Service\bin
C:\Program Files (x86)\CA\ITAM\ITAM RestApi Service\bin
C:\Program Files (x86)\CA\ITAM\LDAP Import Sync Service
C:\Program Files (x86)\CA\ITAM\Registration Service
C:\Program Files (x86)\CA\ITAM\Storage Manager Service\bin
C:\Program Files (x86)\CA\ITAM\WCF Service\bin
C:\Program Files (x86)\CA\ITAM\Web Server\bin

We found that in some of these folders the CA.Common.LoadConfigurationAttributes.dll.config file did have valid values for the highlighted rows above, in others, the values were not set.

Resolution

We concluded the installation did not complete successfully and recommended to rollback and perform the upgrade again.